Configure for MacOS: enable High Sierra (10.13)
[scilab.git] / scilab / m4 / macosx.m4
1 #
2 # Return MacOSX version using system_profile tool.
3 #
4 AC_DEFUN([AC_GET_MACOSX_VERSION],[
5     AC_MSG_CHECKING([Mac OS X Version])
6     [macosx_version=`sw_vers -productVersion`]
7     case $macosx_version in
8          10.13*)
9               AC_MSG_RESULT([macOS 10.13 - High Sierra.])
10          ;;
11          10.12*)
12               AC_MSG_RESULT([macOS 10.12 - Sierra.])
13          ;;
14          10.11*)
15               AC_MSG_RESULT([Mac OS X 10.11 - El Capitan.])
16          ;;
17          10.10*)
18               AC_MSG_RESULT([Mac OS X 10.10 - Yosemite.])
19          ;;
20          10.9*)
21               AC_MSG_RESULT([Mac OS X 10.9 - Mavericks.])
22          ;;
23          10.8.3|10.8.4|10.8.5)
24               AC_MSG_RESULT([Mac OS X $macosx_version - Mountain Lion.])
25          ;;
26          *)
27               AC_MSG_ERROR([MacOSX 10.8.3 to 10.13 are needed. Found $macosx_version])
28          ;;
29     esac
30 ])