* Bug #13752 fixed - The 'Supported compilers' page is outdated
[scilab.git] / scilab / modules / dynamic_link / help / en_US / supported_compilers.xml
1 <?xml version="1.0" encoding="UTF-8"?>
2 <!--
3  * Scilab ( http://www.scilab.org/ ) - This file is part of Scilab
4  * Copyright (C) DIGITEO - 2010-2011 - Allan CORNET
5  *
6  * This file must be used under the terms of the CeCILL.
7  * This source file is licensed as described in the file COPYING, which
8  * you should have received as part of this distribution.  The terms
9  * are also available at
10  * http://www.cecill.info/licences/Licence_CeCILL_V2.1-en.txt
11  *
12  -->
13 <refentry xmlns="http://docbook.org/ns/docbook" xmlns:xlink="http://www.w3.org/1999/xlink" xmlns:svg="http://www.w3.org/2000/svg" xmlns:ns4="http://www.w3.org/1999/xhtml" xmlns:mml="http://www.w3.org/1998/Math/MathML" xmlns:db="http://docbook.org/ns/docbook" scilab:needs-examples="no" xmlns:scilab="http://www.scilab.org" xml:id="supported_compilers" xml:lang="en">
14     <refnamediv>
15         <refname>Supported and compatible compilers</refname>
16         <refpurpose>supported and compatible compilers by Scilab</refpurpose>
17     </refnamediv>
18     <refsection>
19         <title>Scilab supported and compatible compilers</title>
20         <para>Some features of Scilab require that you have a third-party compiler
21             installed on your system.
22         </para>
23     </refsection>
24     <refsection>
25         <title>Windows</title>
26         <para>-- Visual studio C++ 2005, 2008, 2010, 2012, 2013 Professionnal 32 and 64 bits</para>
27         <para>-- Visual studio C++ 2012, 2013 Express Edition (available at no charge)</para>
28         <para>
29             More information is available on <ulink url="http://wiki.scilab.org/How_can_I_set_up_Microsoft_Visual_Studio_2008/2010_Express_Edition_for_use_with_Scilab_x64_on_64-bit_Windows%3F">Scilab Wiki</ulink>.
30         </para>
31         <para>-- Intel Fortran 9, 10, 11, XE 2011, XE 2012, XE 2013</para>
32         <para>
33             -- LCC-Win32 requires to install a ATOMS module:<programlisting role="exec">atomsInstall('lcc_windows'); atomsLoad('lcc_windows');</programlisting>
34         </para>
35         <para>
36             -- MinGW requires to install a ATOMS module:<programlisting role="exec">atomsInstall('mingw'); atomsLoad('mingw');</programlisting>
37         </para>
38     </refsection>
39     <refsection>
40         <title>GNU/Linux</title>
41         <para>On GNU/Linux, GNU compilers (gcc, g++ and gfortran) are packaged in all distributions.</para>
42         <para>
43             While they are not official supported, Scilab supports <ulink url="http://clang.llvm.org/">LLVM/clang</ulink> and Intel compilers.
44         </para>
45     </refsection>
46     <refsection>
47         <title>Mac OS X</title>
48         <para>
49             Apple's development environment for OS X, <ulink url="http://developer.apple.com/technologies/tools/xcode.html">Xcode</ulink>, is available from
50             Apple at no charge.
51         </para>
52     </refsection>
53     <refsection role="see also">
54         <title>See Also</title>
55         <simplelist type="inline">
56             <member>
57                 <link linkend="haveacompiler">haveacompiler</link>
58             </member>
59             <member>
60                 <link linkend="atomsInstall">atomsInstall</link>
61             </member>
62         </simplelist>
63     </refsection>
64 </refentry>