Merge remote-tracking branch 'origin/master' into newsfeed
[scilab.git] / scilab / RELEASE_NOTES_5.3.X
index 29eb123..521407c 100644 (file)
@@ -1,33 +1,32 @@
-                      Scilab 5.3.0 beta 5 Release_Notes
-                      =================================
+                      Scilab 5.3.3 Release_Notes
+                      ==========================
 
-- New Nvidia drivers 260.xx can crash scilab (bug #7575)
-  Workaround: You need to create a 3D graphic profile for wscilex.exe.
-  start Nvidia control panel --> 3d settings --> Manage 3D settings --> Add and 
-  select  wscilex.exe" for Scilab and you disable ("off") for "Threaded 
+
+- The 5.3.3 release is a minor release to tackle two critical bugs causing:
+  * the Japanese and Polish localizations to fail,
+  * the Mac OS X version to fail under Mac OS X 10.6.8 following Apple last update.
+
+- New Nvidia drivers 260.xx could crash Scilab (bug #7575)
+  Workaround: You need to create a 3-D graphic profile for wscilex.exe.
+  start Nvidia control panel --> 3-D settings --> Manage 3-D settings --> Add and
+  select Wscilex.exe" for Scilab and you disable ("off") for "Threaded
   optimization".
   A warning on Scilab startup should be displayed.
+  The latest release of the Nvidia drivers fixes this issue.
 
-- All portability issues of Scilab under Mac OS X (both 10.5 and 10.6) should be
-  fixed. 
-  However, if any problems is encounter, please:
+- All portability issues of Scilab under Mac OS X (10.6.7 and previous 10.6
+  versions) should be fixed.
+  However, if any problem is encountered, please:
   * Test the workaround described here:
     http://bugzilla.scilab.org/show_bug.cgi?id=7012#c10
   * Do not hesitate to report your problem as comment of the bug:
     http://bugzilla.scilab.org/show_bug.cgi?id=7012
 
-- Some issues on startup under Mac OS X have been reported and should be fixed
-  in Scilab 5.3.0:
-  Bug #7012: Error in the detection of the version of Java available.
-  Bug #7433: A segmentation fault on Scilab startup on some Mac OS X 
-  installations.
-
-- The dependencies on the GLIBC 2.7 have been removed. However, on old system,
-  the function parallel_run will not work since it needs a recent version
-  of the OpenMP runtime.
-
-- The accuracy of inversion of most distribution functions is increased: see
-  bug #7569 for details.
+- Some issues on startup under Mac OS X 10.6.7 (and previous 10.6 versions)
+  have been reported.
+  If you have "Audio Hijack" installed on your Mac OS X, it prevents some
+  applications to work including Scilab. See bug #7012.
+  Uninstall / disable Audio Hijack should fix this problem.
 
 Besides these points, do not hesitate to report bugs on:
 http://bugzilla.scilab.org/