Configure for MacOS: enable High Sierra (10.13)
[scilab.git] / scilab / m4 / macosx.m4
index 6adbca3..80f1e09 100644 (file)
@@ -5,8 +5,11 @@ AC_DEFUN([AC_GET_MACOSX_VERSION],[
     AC_MSG_CHECKING([Mac OS X Version])
     [macosx_version=`sw_vers -productVersion`]
     case $macosx_version in
+         10.13*)
+              AC_MSG_RESULT([macOS 10.13 - High Sierra.])
+         ;;
          10.12*)
-              AC_MSG_RESULT([Mac OS X 10.12 - Sierra.])
+              AC_MSG_RESULT([macOS 10.12 - Sierra.])
          ;;
          10.11*)
               AC_MSG_RESULT([Mac OS X 10.11 - El Capitan.])
@@ -21,7 +24,7 @@ AC_DEFUN([AC_GET_MACOSX_VERSION],[
               AC_MSG_RESULT([Mac OS X $macosx_version - Mountain Lion.])
          ;;
          *)
-              AC_MSG_ERROR([MacOSX 10.8.3 to 10.10 are needed. Found $macosx_version])
+              AC_MSG_ERROR([MacOSX 10.8.3 to 10.13 are needed. Found $macosx_version])
          ;;
     esac
 ])