fix trouble on atoms tests since 5.4.0 without libscilab
[scilab.git] / scilab / modules / atoms / tests / unit_tests / atomsIsLoaded.dia.ref
index 04588f8..8d16ddd 100644 (file)
@@ -12,44 +12,41 @@ atomsSaveConfig();
 // Do not use the autoload system
 atomsSetConfig("autoloadAddAfterInstall","False");
 atomsSetConfig("Verbose" ,"False");
-// Load the 2nd scenario : See scene11.test.atoms.scilab.org.txt
-// =============================================================================
-atomsRepositorySetOfl("http://scene10.test.atoms.scilab.org");
+//force official ATOMS repository
+atomsRepositorySetOfl(mgetl(SCI+"/modules/atoms/tests/unit_tests/repositories.orig"));
 // Install toolbox N°2
-atomsInstall(["toolbox_2","2.0"],"user");
+atomsInstall(["toolbox_2","2.1"],"user");
 // Check installation
-if ~ atomsIsInstalled(["toolbox_1","1.0","user"]) then bugmes();quit;end
-if ~ atomsIsInstalled(["toolbox_2","2.0","user"]) then bugmes();quit;end
-atomsLoad(["toolbox_2","2.0","user"]);
+if ~ atomsIsInstalled(["toolbox_1","2.0","user"]) then bugmes();quit;end
+if ~ atomsIsInstalled(["toolbox_2","2.1","user"]) then bugmes();quit;end
+atomsLoad(["toolbox_2","2.1","user"]);
 
 Start Toolbox 1
        Load macros
-       Load gateways
 
 Start Toolbox 2
        Load macros
 
 if ~ atomsIsLoaded("toolbox_2")                  then bugmes();quit;end
-if ~ atomsIsLoaded(["toolbox_2","2.0"])          then bugmes();quit;end
-if ~ atomsIsLoaded(["toolbox_2","2.0","user"])   then bugmes();quit;end
+if ~ atomsIsLoaded(["toolbox_2","2.1"])          then bugmes();quit;end
+if ~ atomsIsLoaded(["toolbox_2","2.1","user"])   then bugmes();quit;end
 if ~ atomsIsLoaded("toolbox_1")                  then bugmes();quit;end
-if ~ atomsIsLoaded(["toolbox_1","1.0"])          then bugmes();quit;end
-if ~ atomsIsLoaded(["toolbox_1","1.0","user"])   then bugmes();quit;end
-if atomsIsLoaded(["toolbox_1","1.0","allusers"]) then bugmes();quit;end
-if atomsIsLoaded(["toolbox_2","2.0","allusers"]) then bugmes();quit;end
-A = [ "toolbox_1" "1.0" "user"     ; ..
-      "toolbox_2" "2.0" "user"     ; ..
+if ~ atomsIsLoaded(["toolbox_1","2.0"])          then bugmes();quit;end
+if ~ atomsIsLoaded(["toolbox_1","2.0","user"])   then bugmes();quit;end
+if atomsIsLoaded(["toolbox_1","2.0","allusers"]) then bugmes();quit;end
+if atomsIsLoaded(["toolbox_2","2.1","allusers"]) then bugmes();quit;end
+A = [ "toolbox_1" "2.0" "user"     ; ..
+      "toolbox_2" "2.1" "user"     ; ..
       "toolbox_2" ""    "user"     ; ..
-      "toolbox_2" "2.0" ""         ; ..
+      "toolbox_2" "2.1" ""         ; ..
       "toolbox_2" ""    ""         ; ..
-      "toolbox_2" "2.0" "allusers" ];
+      "toolbox_2" "2.1" "allusers" ];
 if or(atomsIsLoaded(A) <> [%T ; %T ; %T ; %T ; %T ; %F]) then bugmes();quit;end
 // Remove toolbox_2
 // =============================================================================
 atomsRemove("toolbox_2","user");
-       the package toolbox_2 (2.0-1) is currently loaded, It will be removed at next Scilab start
-       the package toolbox_1 (1.0-1) is currently loaded, It will be removed at next Scilab start
+       the package toolbox_2 (2.1-2) is currently loaded, It will be removed at next Scilab start
+       the package toolbox_1 (2.0-2) is currently loaded, It will be removed at next Scilab start
 // Restore original values
 // =============================================================================
 atomsRestoreConfig(%T);
-atomsRepositorySetOfl(mgetl(SCI+"/modules/atoms/tests/unit_tests/repositories.orig"));