fix trouble on atoms tests since 5.4.0 without libscilab
[scilab.git] / scilab / modules / atoms / tests / unit_tests / atomsLoad.dia.ref
index 1fa5f87..9714a2c 100644 (file)
@@ -13,25 +13,24 @@ if ~isempty( atomsGetInstalled() ) then bugmes();quit;end
 // If previous test did not end properly, restore, else backup config file
 atomsRestoreConfig(%T);
 atomsSaveConfig();
+//force official ATOMS repository
+atomsRepositorySetOfl(mgetl(SCI+"/modules/atoms/tests/unit_tests/repositories.orig"));
 // Set some parameters for the test
 // =============================================================================
 atomsSetConfig("autoloadAddAfterInstall","False");
 atomsSetConfig("Verbose" ,"False");
 // 1st test-case : Just install the toolbox 5
 // =============================================================================
-// Load the 1st scenario : See scene10.test.atoms.scilab.org.txt
-atomsRepositorySetOfl("http://scene10.test.atoms.scilab.org");
 atomsInstall("toolbox_5");
 // Check if the module is really installed
-if ~ and( atomsIsInstalled( ["toolbox_5" "1.0" ; ..
-                             "toolbox_4" "1.0" ; ..
+if ~ and( atomsIsInstalled( ["toolbox_5" "1.2" ; ..
+                             "toolbox_4" "1.1" ; ..
                              "toolbox_2" "1.0" ; ..
-                             "toolbox_1" "1.0"])) then bugmes();quit;end
+                             "toolbox_1" "2.0"])) then bugmes();quit;end
 atomsLoad("toolbox_5");
 
 Start Toolbox 1
        Load macros
-       Load gateways
 
 Start Toolbox 2
        Load macros
@@ -43,25 +42,24 @@ Start Toolbox 5
        Load macros
 
 if ~ atomsIsLoaded("toolbox_5") then bugmes();quit;end
-if ~ atomsIsLoaded(["toolbox_5" "1.0"]) then bugmes();quit;end
+if ~ atomsIsLoaded(["toolbox_5" "1.2"]) then bugmes();quit;end
 if ~ and(atomsIsLoaded(["toolbox_5"; ..
                         "toolbox_2"; ..
                         "toolbox_1"; ..
                         "toolbox_4"])) then bugmes();quit;end
-if ~ and(atomsIsLoaded(["toolbox_5" "1.0"; ..
+if ~ and(atomsIsLoaded(["toolbox_5" "1.2"; ..
                         "toolbox_2" "1.0"; ..
-                        "toolbox_1" "1.0"; ..
-                        "toolbox_4" "1.0"])) then bugmes();quit;end
-if or( t5_version() <> ["Toolbox 5 -> version = 1.0"; ..
-                        "Toolbox 4 -> version = 1.0"; ..
+                        "toolbox_1" "2.0"; ..
+                        "toolbox_4" "1.1"])) then bugmes();quit;end
+if or( t5_version() <> ["Toolbox 5 -> version = 1.2"; ..
+                        "Toolbox 4 -> version = 1.1"; ..
                         "Toolbox 2 -> version = 1.0"; ..
-                        "Toolbox 1 -> version = 1.0" ] ) then bugmes();quit;end
+                        "Toolbox 1 -> version = 2.0" ] ) then bugmes();quit;end
 atomsRemove("toolbox_5");
-       the package toolbox_5 (1.0-1) is currently loaded, It will be removed at next Scilab start
-       the package toolbox_4 (1.0-1) is currently loaded, It will be removed at next Scilab start
-       the package toolbox_2 (1.0-1) is currently loaded, It will be removed at next Scilab start
-       the package toolbox_1 (1.0-1) is currently loaded, It will be removed at next Scilab start
+       the package toolbox_5 (1.2-2) is currently loaded, It will be removed at next Scilab start
+       the package toolbox_4 (1.1-2) is currently loaded, It will be removed at next Scilab start
+       the package toolbox_2 (1.0-2) is currently loaded, It will be removed at next Scilab start
+       the package toolbox_1 (2.0-2) is currently loaded, It will be removed at next Scilab start
 // Restore original values
 // =============================================================================
 atomsRestoreConfig(%T);
-atomsRepositorySetOfl(mgetl(SCI+"/modules/atoms/tests/unit_tests/repositories.orig"));