* Enforce a minimal version of JLaTeXMath (1.0.1). 02/10602/3
Sylvestre Ledru [Mon, 25 Feb 2013 14:19:43 +0000 (15:19 +0100)]
Change-Id: I0b4e53c7dcd8a82b6aec6d1fed612f1411040a3b

scilab/CHANGES_5.4.X
scilab/configure
scilab/configure.ac
scilab/etc/classpath.xml.vc
scilab/modules/graphics/graphics.iss
scilab/scilab-lib-doc.properties.vc
scilab/scilab-lib.properties.vc

index a2a699c..cbd35d4 100644 (file)
@@ -174,6 +174,7 @@ Compilation
 
 * Enforce a minimal version of Flexdock (1.2.3).
 
+* Enforce a minimal version of JLaTeXMath (1.0.1).
 
 Bug fixes
 ==========
index c379849..a956347 100755 (executable)
@@ -16081,8 +16081,8 @@ $as_echo "$as_me: WARNING: Could not find or use the Java package/jar jlatexmath
 
 
 
-    { $as_echo "$as_me:${as_lineno-$LINENO}: checking minimal version (1.0.0) of jlatexmath" >&5
-$as_echo_n "checking minimal version (1.0.0) of jlatexmath... " >&6; }
+    { $as_echo "$as_me:${as_lineno-$LINENO}: checking minimal version (1.0.1) of jlatexmath" >&5
+$as_echo_n "checking minimal version (1.0.1) of jlatexmath... " >&6; }
    saved_ac_java_classpath=$ac_java_classpath
    export ac_java_classpath="$JLATEXMATH:$ac_java_classpath"
    if test "x" == "x"; then
@@ -16095,7 +16095,7 @@ import org.scilab.forge.jlatexmath.TeXFormula;
 
 public class conftest {
     public static void main(String[] argv) {
-        String minVersion="1.0.0";
+        String minVersion="1.0.1";
 
                             System.out.println(TeXFormula.VERSION);
                                   if (compare(minVersion, TeXFormula.VERSION) > 0) {
@@ -16144,7 +16144,7 @@ EOF
                    STDOUT=`cat conftest.java.output`
                 fi
                 echo "configure: CLASSPATH was $CLASSPATH" >&5
-                  as_fn_error $? "Wrong version of jlatexmath. Expected at least 1.0.0. Found $STDOUT" "$LINENO" 5
+                  as_fn_error $? "Wrong version of jlatexmath. Expected at least 1.0.1. Found $STDOUT" "$LINENO" 5
                             fi
         fi
         if test -f conftest.java.output; then
@@ -16154,7 +16154,7 @@ EOF
         echo "configure: failed program was:" >&5
         cat conftest.java >&5
         echo "configure: CLASSPATH was $CLASSPATH" >&5
-          as_fn_error $? "Wrong version of jlatexmath. Expected at least 1.0.0. Found $STDOUT" "$LINENO" 5
+          as_fn_error $? "Wrong version of jlatexmath. Expected at least 1.0.1. Found $STDOUT" "$LINENO" 5
             fi
 
    else
@@ -16167,7 +16167,7 @@ import org.scilab.forge.jlatexmath.TeXFormula;
 
 public class conftest {
     public static void main(String[] argv) {
-        String minVersion="1.0.0";
+        String minVersion="1.0.1";
 
                             System.out.println(TeXFormula.VERSION);
                                   if (compare(minVersion, TeXFormula.VERSION) != 0) {
@@ -16216,7 +16216,7 @@ EOF
                    STDOUT=`cat conftest.java.output`
                 fi
                 echo "configure: CLASSPATH was $CLASSPATH" >&5
-                  as_fn_error $? "Wrong version of jlatexmath. Expected exact version 1.0.0. Found $STDOUT" "$LINENO" 5
+                  as_fn_error $? "Wrong version of jlatexmath. Expected exact version 1.0.1. Found $STDOUT" "$LINENO" 5
                             fi
         fi
         if test -f conftest.java.output; then
@@ -16226,7 +16226,7 @@ EOF
         echo "configure: failed program was:" >&5
         cat conftest.java >&5
         echo "configure: CLASSPATH was $CLASSPATH" >&5
-          as_fn_error $? "Wrong version of jlatexmath. Expected exact version 1.0.0. Found $STDOUT" "$LINENO" 5
+          as_fn_error $? "Wrong version of jlatexmath. Expected exact version 1.0.1. Found $STDOUT" "$LINENO" 5
             fi
 
     fi
index 07eb8b9..88d4ee0 100644 (file)
@@ -1025,7 +1025,7 @@ interface for JOGL2 - or libGL (OpenGL library) are installed and if the version
                 JLATEXMATH=$PACKAGE_JAR_FILE
                 AC_SUBST(JLATEXMATH)
 
-                AC_JAVA_CHECK_VERSION_PACKAGE([jlatexmath],[import org.scilab.forge.jlatexmath.TeXFormula;],$JLATEXMATH,[1.0.0],[TeXFormula.VERSION])
+                AC_JAVA_CHECK_VERSION_PACKAGE([jlatexmath],[import org.scilab.forge.jlatexmath.TeXFormula;],$JLATEXMATH,[1.0.1],[TeXFormula.VERSION])
 
                 AC_DEFINE([WITH_GUI],[],[With the JAVA stuff (GUI, Console, JOGL...)])
 
index 6aa0510..5979b8d 100644 (file)
@@ -79,7 +79,7 @@ The option is "disableUnderMode" and can be:
        <load on="xcos_mathml_rendering"/>
 </path>
 
-<path value="$SCILAB/thirdparty/jlatexmath-fop-1.0.0.jar" load="onUse">
+<path value="$SCILAB/thirdparty/jlatexmath-fop-1.0.1.jar" load="onUse">
        <load on="documentationGeneration"/>
        <load on="pdf_ps_eps_graphic_export"/>
 </path>
@@ -123,7 +123,7 @@ The option is "disableUnderMode" and can be:
        <load on="pdf_ps_eps_graphic_export"/>
 </path>
 
-<path value="$SCILAB/thirdparty/jlatexmath-1.0.0.jar" load="onUse">
+<path value="$SCILAB/thirdparty/jlatexmath-1.0.1.jar" load="onUse">
        <load on="documentationGeneration"/>
        <load on="graphics_latex_textrendering"/>
        <load on="pdf_ps_eps_graphic_export"/>
index 806f8a6..79dbbb5 100644 (file)
@@ -20,8 +20,8 @@
 ;
 Source: modules\{#GRAPHICS}\license.txt; DestDir: {app}\modules\{#GRAPHICS}; Components: {#COMPN_GRAPHICS}
 ;
-Source: thirdparty\jlatexmath-1.0.0.jar;DestDir: {app}\thirdparty; Components: {#COMPN_GRAPHICS}
-Source: thirdparty\jlatexmath-fop-1.0.0.jar;DestDir: {app}\thirdparty; Components: {#COMPN_GRAPHICS}
+Source: thirdparty\jlatexmath-1.0.1.jar;DestDir: {app}\thirdparty; Components: {#COMPN_GRAPHICS}
+Source: thirdparty\jlatexmath-fop-1.0.1.jar;DestDir: {app}\thirdparty; Components: {#COMPN_GRAPHICS}
 ;
 Source: bin\{#GRAPHICS}.dll; DestDir: {app}\bin; Components: {#COMPN_GRAPHICS}
 ;
index f8360c8..a358493 100644 (file)
@@ -1,20 +1,20 @@
-; Definition of lib for documentation build used in Scilab 
+; Definition of lib for documentation build used in Scilab
 
 xml_apis_ext.jar =${thirdparty.dir}/xml_apis_ext.jar
 
-; xml.apache.org SVG Library 
+; xml.apache.org SVG Library
 batik.jar=${thirdparty.dir}/batik-all-1.7.jar
 
-; The Saxon XSLT Processor 
+; The Saxon XSLT Processor
 saxon.jar=${thirdparty.dir}/saxon.jar
 
-; Reusable components used by Batik and FOP 
+; Reusable components used by Batik and FOP
 fop.jar=${thirdparty.dir}/fop.jar
 
 ; LaTeX plugin
-jlatexmath-fop.jar=${thirdparty.dir}/jlatexmath-fop-1.0.0.jar
+jlatexmath-fop.jar=${thirdparty.dir}/jlatexmath-fop-1.0.1.jar
 
-; A complete MathML rendering solution 
+; A complete MathML rendering solution
 jeuclid-core.jar=${thirdparty.dir}/jeuclid-core.jar
 
 library.helptools.dir=${modules.dir}/helptools/${build.jar.dir}/
index 0963b90..acd2244 100644 (file)
@@ -18,9 +18,9 @@ jrosetta-API.jar=${thirdparty.dir}/jrosetta-API.jar
 
 jrosetta-engine.jar=${thirdparty.dir}/jrosetta-engine.jar
 
-jlatexmath.jar=${thirdparty.dir}/jlatexmath-1.0.0.jar
+jlatexmath.jar=${thirdparty.dir}/jlatexmath-1.0.1.jar
 
-jlatexmath-fop.jar=${thirdparty.dir}/jlatexmath-fop-1.0.0.jar
+jlatexmath-fop.jar=${thirdparty.dir}/jlatexmath-fop-1.0.1.jar
 
 checkstyle.jar=${thirdparty.dir}/checkstyle/checkstyle-5.3-all.jar