Enforce C formatting or new images won't build 78/18278/3
Paul Bignier [Tue, 21 Jun 2016 09:42:38 +0000 (11:42 +0200)]
 * For instance when that command launched a French Scilab, "0.1" yielded "0,"
 * Was invisible because no images were remade when 'make doc' was called

Change-Id: I508a56875bd072d9ad05a5893df7a91381736c8a

scilab/Makefile.am
scilab/Makefile.in

index ee3a8d9..53ebc0a 100644 (file)
@@ -91,7 +91,7 @@ scilab_bin_CPPFLAGS = \
 # (causing issues on some platform)
 COMMON_LIBS = $(LTLIBINTL)
 
-# Link against valgrind library as on some systems (eg. Fedora) it should be 
+# Link against valgrind library as on some systems (eg. Fedora) it should be
 # link on the final binary
 COMMON_LIBS += $(VALGRIND_LIBS)
 
@@ -278,8 +278,8 @@ if BUILD_HELP
                for l in $(ALL_LINGUAS_DOC); do \
                        echo "-- Building documentation ($$l) --"; \
                        COMMAND="try xmltojar([],[],'$$l');catch disp(lasterror()); exit(-1);end;exit(0);"; \
-                       echo "LANG=$$l.UTF-8 LC_ALL=$$l.UTF-8 SCI_DISABLE_TK=1 SCI_JAVA_ENABLE_HEADLESS=1 _JAVA_OPTIONS='-Djava.awt.headless=true' $(top_builddir)/bin/scilab-adv-cli -noatomsautoload -nb -l $$l -nouserstartup -e \"$$COMMAND\"";\
-                       LANG=$$l.UTF-8 LC_ALL=$$l.UTF-8 SCI_DISABLE_TK=1 SCI_JAVA_ENABLE_HEADLESS=1 _JAVA_OPTIONS='-Djava.awt.headless=true' $(top_builddir)/bin/scilab-adv-cli -noatomsautoload -nb -l $$l -nouserstartup -e "$$COMMAND" || exit 1;\
+                       echo "LANG=$$l.UTF-8 LC_ALL=C SCI_DISABLE_TK=1 SCI_JAVA_ENABLE_HEADLESS=1 _JAVA_OPTIONS='-Djava.awt.headless=true' $(top_builddir)/bin/scilab-adv-cli -noatomsautoload -nb -l $$l -nouserstartup -e \"$$COMMAND\"";\
+                       LANG=$$l.UTF-8 LC_ALL=C SCI_DISABLE_TK=1 SCI_JAVA_ENABLE_HEADLESS=1 _JAVA_OPTIONS='-Djava.awt.headless=true' $(top_builddir)/bin/scilab-adv-cli -noatomsautoload -nb -l $$l -nouserstartup -e "$$COMMAND" || exit 1;\
                done; \
        else \
                echo "Cannot find Scilab-adv-cli binary"; \
index fa3fcf5..c880aaa 100644 (file)
@@ -864,7 +864,7 @@ scilab_bin_CPPFLAGS = -I$(top_srcdir)/modules/ast/includes/ast/ \
 # Localization dep already exists because of the `exportLocaleToSystem' symbol
 # (causing issues on some platform)
 
-# Link against valgrind library as on some systems (eg. Fedora) it should be 
+# Link against valgrind library as on some systems (eg. Fedora) it should be
 # link on the final binary
 COMMON_LIBS = $(LTLIBINTL) $(VALGRIND_LIBS)
 scilab_bin_SOURCES = modules/startup/src/cpp/scilab.cpp \
@@ -2210,8 +2210,8 @@ doc: javadoc $(top_builddir)/scilab-bin $(top_builddir)/bin/scilab-adv-cli
 @BUILD_HELP_TRUE@              for l in $(ALL_LINGUAS_DOC); do \
 @BUILD_HELP_TRUE@                      echo "-- Building documentation ($$l) --"; \
 @BUILD_HELP_TRUE@                      COMMAND="try xmltojar([],[],'$$l');catch disp(lasterror()); exit(-1);end;exit(0);"; \
-@BUILD_HELP_TRUE@                      echo "LANG=$$l.UTF-8 LC_ALL=$$l.UTF-8 SCI_DISABLE_TK=1 SCI_JAVA_ENABLE_HEADLESS=1 _JAVA_OPTIONS='-Djava.awt.headless=true' $(top_builddir)/bin/scilab-adv-cli -noatomsautoload -nb -l $$l -nouserstartup -e \"$$COMMAND\"";\
-@BUILD_HELP_TRUE@                      LANG=$$l.UTF-8 LC_ALL=$$l.UTF-8 SCI_DISABLE_TK=1 SCI_JAVA_ENABLE_HEADLESS=1 _JAVA_OPTIONS='-Djava.awt.headless=true' $(top_builddir)/bin/scilab-adv-cli -noatomsautoload -nb -l $$l -nouserstartup -e "$$COMMAND" || exit 1;\
+@BUILD_HELP_TRUE@                      echo "LANG=$$l.UTF-8 LC_ALL=C SCI_DISABLE_TK=1 SCI_JAVA_ENABLE_HEADLESS=1 _JAVA_OPTIONS='-Djava.awt.headless=true' $(top_builddir)/bin/scilab-adv-cli -noatomsautoload -nb -l $$l -nouserstartup -e \"$$COMMAND\"";\
+@BUILD_HELP_TRUE@                      LANG=$$l.UTF-8 LC_ALL=C SCI_DISABLE_TK=1 SCI_JAVA_ENABLE_HEADLESS=1 _JAVA_OPTIONS='-Djava.awt.headless=true' $(top_builddir)/bin/scilab-adv-cli -noatomsautoload -nb -l $$l -nouserstartup -e "$$COMMAND" || exit 1;\
 @BUILD_HELP_TRUE@              done; \
 @BUILD_HELP_TRUE@      else \
 @BUILD_HELP_TRUE@              echo "Cannot find Scilab-adv-cli binary"; \