Switch to ecj 4.4.2 (for compatibility with Java 8) 85/16885/2
Vincent COUVERT [Thu, 23 Jul 2015 11:44:40 +0000 (13:44 +0200)]
Change-Id: I331ba74432bf229e11ca8660f345337cf23c5645

scilab/CHANGES_6.0.X
scilab/modules/external_objects_java/src/java/org/scilab/modules/external_objects_java/ScilabJavaCompiler.java

index 23dda2d..d9cbcc5 100644 (file)
@@ -15,7 +15,9 @@ Compilation
 
 * Java minimal version switch to 1.8.
 
-* Ant minimal version switched to 1.9.0 (for xompatibility with Java 1.8).
+* Ant minimal version switched to 1.9.0 (for compatibility with Java 1.8).
+
+* ecj minimal version switched to 4.4.0 (for compatibility with Java 1.8).
 
 
 Packaging & Supported operating systems
index da636d2..d8b88df 100644 (file)
@@ -97,7 +97,7 @@ public class ScilabJavaCompiler {
 
             if (compiler == null) {
                 if (ecjLoaded) {
-                    throw new ScilabJavaException("No java compiler in the classpath\nCheck for tools.jar (comes from JDK) or ecj-3.6.x.jar (Eclipse Compiler for Java)");
+                    throw new ScilabJavaException("No java compiler in the classpath\nCheck for tools.jar (comes from JDK) or ecj-4.4.x.jar (Eclipse Compiler for Java)");
                 }
 
                 // Compiler should be in thirdparty so we load it