Remove Mac OS X 10.5 parts (Scilab 5.5.2 was already compiled with --with-min-macosx... 70/16770/1
Vincent COUVERT [Fri, 3 Jul 2015 08:29:26 +0000 (10:29 +0200)]
Change-Id: Id9cbbfb4b4d4e7421c2e3b90666494e901cb4cc9

scilab/bin/scilab
scilab/m4/macosx.m4

index 48ae1f4..8fba34d 100755 (executable)
@@ -713,7 +713,6 @@ set_macox_specific_path()
 
     PATH_TO_SPECIFIC_10_10=$SCIBINARYBASE/lib/thirdparty/10.10/
     PATH_TO_SPECIFIC_10_6=$SCIBINARYBASE/lib/thirdparty/10.6/
-    PATH_TO_SPECIFIC_10_5=$SCIBINARYBASE/lib/thirdparty/10.5/
 
     case $macosxMajorVersion in
         10)
@@ -724,17 +723,10 @@ set_macox_specific_path()
                     DYLD_LIBRARY_PATH=$PATH_TO_SPECIFIC_10_10${DYLD_LIBRARY_PATH+:$DYLD_LIBRARY_PATH}
                     ;;
                 6)
-                    # the iconv lib fails under 10.7, just declare it for 10.5 & 10.6
+                    # the iconv lib fails under 10.7, just declare it for 10.6
                     LD_LIBRARY_PATH=$PATH_TO_SPECIFIC_10_6${LD_LIBRARY_PATH+:$LD_LIBRARY_PATH}
                     DYLD_LIBRARY_PATH=$PATH_TO_SPECIFIC_10_6${DYLD_LIBRARY_PATH+:$DYLD_LIBRARY_PATH}
                     ;;
-                 5)
-                    # the iconv lib fails under 10.7, just declare it for 10.5 & 10.6
-                    LD_LIBRARY_PATH=$PATH_TO_SPECIFIC_10_6${LD_LIBRARY_PATH+:$LD_LIBRARY_PATH}
-                    DYLD_LIBRARY_PATH=$PATH_TO_SPECIFIC_10_6${DYLD_LIBRARY_PATH+:$DYLD_LIBRARY_PATH}
-                    LD_LIBRARY_PATH=$PATH_TO_SPECIFIC_10_5${LD_LIBRARY_PATH+:$LD_LIBRARY_PATH}
-                    DYLD_LIBRARY_PATH=$PATH_TO_SPECIFIC_10_5${DYLD_LIBRARY_PATH+:$DYLD_LIBRARY_PATH}
-                    ;;
             esac
             ;;
     esac
@@ -762,19 +754,6 @@ check_macosx_version()
                         osascript $BINPATH/checkmacosx.applescript $macosxVersion "10.6.5 (Snow Leopard) or newer system" || exit 128
                     fi
                     ;;
-                 5)
-                     if test $macosxBuildVersion -le 7; then
-                         # Version <= 10.5.8
-                         osascript $BINPATH/checkmacosx.applescript $macosxVersion "10.5.8 (Leopard) or newer system" || exit 128
-                     fi
-                     # Check if the default java is not 1.5 (magic)
-                     VERSION=$(/usr/libexec/java_home -v 1.5|grep 1.5.0)
-                     if test "$VERSION"; then
-                         open /Applications/Utilities/Java\ Preferences.app/ &
-                         osascript $BINPATH/checkmacosx.applescript $macosxVersion "Java 6 or newer. Please disable any version of Java 1.5 in the Java Preferences menu. An other workaround is to rename /System/Library/Frameworks/JavaVM.framework/Versions/1.5.0/Libraries/libjava.jnilib to libjava.jnilib_" || exit 128
-                     fi
-
-                     ;;
                 *)
                     osascript $BINPATH/checkmacosx.applescript $macosxVersion "10.6.5 (Snow Leopard) or newer system" || exit 128
                     ;;
index ada4b8f..fbec1cf 100644 (file)
@@ -20,11 +20,8 @@ AC_DEFUN([AC_GET_MACOSX_VERSION],[
          10.6*)
               AC_MSG_RESULT([Mac OS X 10.6 - Snow Leopard.])
          ;;
-         *10.5*)
-              AC_MSG_RESULT([Mac OS X 10.5 - Leopard.])
-         ;;
          *)
-              AC_MSG_ERROR([MacOSX 10.5 to 10.10 are needed. Found $macosx_version])
+              AC_MSG_ERROR([MacOSX 10.6 to 10.10 are needed. Found $macosx_version])
          ;;
-        esac
+    esac
 ])