JLaTeXmath 0.9.7 => 1.0.0 26/9126/1
Sylvestre Ledru [Mon, 24 Sep 2012 15:27:54 +0000 (17:27 +0200)]
Change-Id: I81d0a47a3283341a0766df0f5b0a8fb4c0c43e00

scilab/configure
scilab/configure.ac
scilab/etc/classpath.xml.vc
scilab/modules/graphics/graphics.iss
scilab/scilab-lib-doc.properties.vc
scilab/scilab-lib.properties.vc

index f3934a3..c19a411 100755 (executable)
@@ -16076,8 +16076,8 @@ $as_echo "$as_me: WARNING: Could not find or use the Java package/jar jlatexmath
 
 
 
-    { $as_echo "$as_me:${as_lineno-$LINENO}: checking minimal version (0.9.7) of jlatexmath" >&5
-$as_echo_n "checking minimal version (0.9.7) of jlatexmath... " >&6; }
+    { $as_echo "$as_me:${as_lineno-$LINENO}: checking minimal version (1.0.0) of jlatexmath" >&5
+$as_echo_n "checking minimal version (1.0.0) of jlatexmath... " >&6; }
    saved_ac_java_classpath=$ac_java_classpath
    export ac_java_classpath="$JLATEXMATH:$ac_java_classpath"
    if test "x" == "x"; then
@@ -16090,7 +16090,7 @@ import org.scilab.forge.jlatexmath.TeXFormula;
 
 public class conftest {
     public static void main(String[] argv) {
-        String minVersion="0.9.7";
+        String minVersion="1.0.0";
 
                             System.out.println(TeXFormula.VERSION);
                                   if (compare(minVersion, TeXFormula.VERSION) > 0) {
@@ -16139,7 +16139,7 @@ EOF
                    STDOUT=`cat conftest.java.output`
                 fi
                 echo "configure: CLASSPATH was $CLASSPATH" >&5
-                  as_fn_error $? "Wrong version of jlatexmath. Expected at least 0.9.7. Found $STDOUT" "$LINENO" 5
+                  as_fn_error $? "Wrong version of jlatexmath. Expected at least 1.0.0. Found $STDOUT" "$LINENO" 5
                             fi
         fi
         if test -f conftest.java.output; then
@@ -16149,7 +16149,7 @@ EOF
         echo "configure: failed program was:" >&5
         cat conftest.java >&5
         echo "configure: CLASSPATH was $CLASSPATH" >&5
-          as_fn_error $? "Wrong version of jlatexmath. Expected at least 0.9.7. Found $STDOUT" "$LINENO" 5
+          as_fn_error $? "Wrong version of jlatexmath. Expected at least 1.0.0. Found $STDOUT" "$LINENO" 5
             fi
 
    else
@@ -16162,7 +16162,7 @@ import org.scilab.forge.jlatexmath.TeXFormula;
 
 public class conftest {
     public static void main(String[] argv) {
-        String minVersion="0.9.7";
+        String minVersion="1.0.0";
 
                             System.out.println(TeXFormula.VERSION);
                                   if (compare(minVersion, TeXFormula.VERSION) != 0) {
@@ -16211,7 +16211,7 @@ EOF
                    STDOUT=`cat conftest.java.output`
                 fi
                 echo "configure: CLASSPATH was $CLASSPATH" >&5
-                  as_fn_error $? "Wrong version of jlatexmath. Expected exact version 0.9.7. Found $STDOUT" "$LINENO" 5
+                  as_fn_error $? "Wrong version of jlatexmath. Expected exact version 1.0.0. Found $STDOUT" "$LINENO" 5
                             fi
         fi
         if test -f conftest.java.output; then
@@ -16221,7 +16221,7 @@ EOF
         echo "configure: failed program was:" >&5
         cat conftest.java >&5
         echo "configure: CLASSPATH was $CLASSPATH" >&5
-          as_fn_error $? "Wrong version of jlatexmath. Expected exact version 0.9.7. Found $STDOUT" "$LINENO" 5
+          as_fn_error $? "Wrong version of jlatexmath. Expected exact version 1.0.0. Found $STDOUT" "$LINENO" 5
             fi
 
     fi
index 843b66c..4536244 100644 (file)
@@ -1025,7 +1025,7 @@ interface for JOGL2 - or libGL (OpenGL library) are installed and if the version
                 JLATEXMATH=$PACKAGE_JAR_FILE
                 AC_SUBST(JLATEXMATH)
 
-                AC_JAVA_CHECK_VERSION_PACKAGE([jlatexmath],[import org.scilab.forge.jlatexmath.TeXFormula;],$JLATEXMATH,[0.9.7],[TeXFormula.VERSION])
+                AC_JAVA_CHECK_VERSION_PACKAGE([jlatexmath],[import org.scilab.forge.jlatexmath.TeXFormula;],$JLATEXMATH,[1.0.0],[TeXFormula.VERSION])
 
                 AC_DEFINE([WITH_GUI],[],[With the JAVA stuff (GUI, Console, JOGL...)])
 
index bb63caa..764e670 100644 (file)
@@ -82,7 +82,7 @@ The option is "disableUnderMode" and can be:
        <load on="xcos_mathml_rendering"/>
 </path>
 
-<path value="$SCILAB/thirdparty/jlatexmath-fop-0.9.7.jar" load="onUse">
+<path value="$SCILAB/thirdparty/jlatexmath-fop-1.0.0.jar" load="onUse">
        <load on="documentationGeneration"/>
        <load on="pdf_ps_eps_graphic_export"/>
 </path>
@@ -126,7 +126,7 @@ The option is "disableUnderMode" and can be:
        <load on="pdf_ps_eps_graphic_export"/>
 </path>
 
-<path value="$SCILAB/thirdparty/jlatexmath-0.9.7.jar" load="onUse">
+<path value="$SCILAB/thirdparty/jlatexmath-1.0.0.jar" load="onUse">
        <load on="documentationGeneration"/>
        <load on="graphics_latex_textrendering"/>
        <load on="pdf_ps_eps_graphic_export"/>
index 523734e..806f8a6 100644 (file)
@@ -20,8 +20,8 @@
 ;
 Source: modules\{#GRAPHICS}\license.txt; DestDir: {app}\modules\{#GRAPHICS}; Components: {#COMPN_GRAPHICS}
 ;
-Source: thirdparty\jlatexmath-0.9.7.jar;DestDir: {app}\thirdparty; Components: {#COMPN_GRAPHICS}
-Source: thirdparty\jlatexmath-fop-0.9.7.jar;DestDir: {app}\thirdparty; Components: {#COMPN_GRAPHICS}
+Source: thirdparty\jlatexmath-1.0.0.jar;DestDir: {app}\thirdparty; Components: {#COMPN_GRAPHICS}
+Source: thirdparty\jlatexmath-fop-1.0.0.jar;DestDir: {app}\thirdparty; Components: {#COMPN_GRAPHICS}
 ;
 Source: bin\{#GRAPHICS}.dll; DestDir: {app}\bin; Components: {#COMPN_GRAPHICS}
 ;
index 0bd1b8c..f8360c8 100644 (file)
@@ -12,7 +12,7 @@ saxon.jar=${thirdparty.dir}/saxon.jar
 fop.jar=${thirdparty.dir}/fop.jar
 
 ; LaTeX plugin
-jlatexmath-fop.jar=${thirdparty.dir}/jlatexmath-fop-0.9.7.jar
+jlatexmath-fop.jar=${thirdparty.dir}/jlatexmath-fop-1.0.0.jar
 
 ; A complete MathML rendering solution 
 jeuclid-core.jar=${thirdparty.dir}/jeuclid-core.jar
index c1a8585..45c87e3 100644 (file)
@@ -18,9 +18,9 @@ jrosetta-API.jar=${thirdparty.dir}/jrosetta-API.jar
 
 jrosetta-engine.jar=${thirdparty.dir}/jrosetta-engine.jar
 
-jlatexmath.jar=${thirdparty.dir}/jlatexmath-0.9.7.jar
+jlatexmath.jar=${thirdparty.dir}/jlatexmath-1.0.0.jar
 
-jlatexmath-fop.jar=${thirdparty.dir}/jlatexmath-fop-0.9.7.jar
+jlatexmath-fop.jar=${thirdparty.dir}/jlatexmath-fop-1.0.0.jar
 
 checkstyle.jar=${thirdparty.dir}/checkstyle/checkstyle-5.3-all.jar