Compilation 72/10072/1
Sylvestre Ledru [Fri, 21 Dec 2012 10:18:34 +0000 (11:18 +0100)]
============

* Enforce a minimal version of Scirenderer (1.0.3).

Change-Id: I10e0e709e633ab4bcf5695c2289a24e090056711

scilab/CHANGES_5.4.X
scilab/configure
scilab/configure.ac
scilab/etc/classpath.xml.vc
scilab/modules/renderer/renderer.iss
scilab/scilab-lib.properties.vc

index 2e56ea9..d733558 100644 (file)
@@ -96,6 +96,12 @@ Documentation
 * Add the 'scilab:needs-examples="no"' tag to specify that the help page does not need any example.
 
 
+Compilation
+============
+
+* Enforce a minimal version of Scirenderer (1.0.3).
+
+
 Bug fixes
 ==========
 
index ce972b0..22a0d55 100755 (executable)
@@ -12724,8 +12724,8 @@ $as_echo "$as_me: WARNING: Could not find or use the Java package/jar scirendere
 
 
 
-    { $as_echo "$as_me:${as_lineno-$LINENO}: checking minimal version (1.0.2) of scirenderer" >&5
-$as_echo_n "checking minimal version (1.0.2) of scirenderer... " >&6; }
+    { $as_echo "$as_me:${as_lineno-$LINENO}: checking minimal version (1.0.3) of scirenderer" >&5
+$as_echo_n "checking minimal version (1.0.3) of scirenderer... " >&6; }
    saved_ac_java_classpath=$ac_java_classpath
    export ac_java_classpath="$SCIRENDERER:$ac_java_classpath"
    if test "x" == "x"; then
@@ -12738,7 +12738,7 @@ import org.scilab.forge.scirenderer.PackageInfo;
 
 public class conftest {
     public static void main(String[] argv) {
-        String minVersion="1.0.2";
+        String minVersion="1.0.3";
 
                             System.out.println(PackageInfo.VERSION);
                                   if (compare(minVersion, PackageInfo.VERSION) > 0) {
@@ -12787,7 +12787,7 @@ EOF
                    STDOUT=`cat conftest.java.output`
                 fi
                 echo "configure: CLASSPATH was $CLASSPATH" >&5
-                  as_fn_error $? "Wrong version of scirenderer. Expected at least 1.0.2. Found $STDOUT" "$LINENO" 5
+                  as_fn_error $? "Wrong version of scirenderer. Expected at least 1.0.3. Found $STDOUT" "$LINENO" 5
                             fi
         fi
         if test -f conftest.java.output; then
@@ -12797,7 +12797,7 @@ EOF
         echo "configure: failed program was:" >&5
         cat conftest.java >&5
         echo "configure: CLASSPATH was $CLASSPATH" >&5
-          as_fn_error $? "Wrong version of scirenderer. Expected at least 1.0.2. Found $STDOUT" "$LINENO" 5
+          as_fn_error $? "Wrong version of scirenderer. Expected at least 1.0.3. Found $STDOUT" "$LINENO" 5
             fi
 
    else
@@ -12810,7 +12810,7 @@ import org.scilab.forge.scirenderer.PackageInfo;
 
 public class conftest {
     public static void main(String[] argv) {
-        String minVersion="1.0.2";
+        String minVersion="1.0.3";
 
                             System.out.println(PackageInfo.VERSION);
                                   if (compare(minVersion, PackageInfo.VERSION) != 0) {
@@ -12859,7 +12859,7 @@ EOF
                    STDOUT=`cat conftest.java.output`
                 fi
                 echo "configure: CLASSPATH was $CLASSPATH" >&5
-                  as_fn_error $? "Wrong version of scirenderer. Expected exact version 1.0.2. Found $STDOUT" "$LINENO" 5
+                  as_fn_error $? "Wrong version of scirenderer. Expected exact version 1.0.3. Found $STDOUT" "$LINENO" 5
                             fi
         fi
         if test -f conftest.java.output; then
@@ -12869,7 +12869,7 @@ EOF
         echo "configure: failed program was:" >&5
         cat conftest.java >&5
         echo "configure: CLASSPATH was $CLASSPATH" >&5
-          as_fn_error $? "Wrong version of scirenderer. Expected exact version 1.0.2. Found $STDOUT" "$LINENO" 5
+          as_fn_error $? "Wrong version of scirenderer. Expected exact version 1.0.3. Found $STDOUT" "$LINENO" 5
             fi
 
     fi
index da8010b..6cd7336 100644 (file)
@@ -859,7 +859,7 @@ if test "$with_javasci" != no -o "$with_gui" != no -o "$enable_build_help" != no
                 SCIRENDERER=$PACKAGE_JAR_FILE
                 AC_SUBST(SCIRENDERER)
 
-                AC_JAVA_CHECK_VERSION_PACKAGE([scirenderer],[import org.scilab.forge.scirenderer.PackageInfo;],$SCIRENDERER,[1.0.2],[PackageInfo.VERSION])
+                AC_JAVA_CHECK_VERSION_PACKAGE([scirenderer],[import org.scilab.forge.scirenderer.PackageInfo;],$SCIRENDERER,[1.0.3],[PackageInfo.VERSION])
 
                # Docking system
                 AC_JAVA_CHECK_PACKAGE([flexdock],[org.flexdock.docking.DockingManager],[Scilab Gui])
index dd73785..b0f1037 100644 (file)
@@ -50,7 +50,7 @@ The option is "disableUnderMode" and can be:
        <load on="documentationGeneration"/>
 </path>
 
-<path value="$SCILAB/thirdparty/scirenderer-1.0.2.jar" load="onUse">
+<path value="$SCILAB/thirdparty/scirenderer-1.0.3.jar" load="onUse">
     <load on="graphics"/>
     <load on="graphic_ojects"/>
     <load on="Xcos"/>
index a82ad7b..82c990b 100644 (file)
@@ -31,7 +31,7 @@ Source: bin\sci{#RENDERER}.dll; DestDir: {app}\bin; Components: {#COMPN_GRAPHICS
 Source: thirdparty\gluegen2-rt.jar; DestDir: {app}\thirdparty; Components: {#COMPN_GRAPHICS}
 Source: thirdparty\jogl2.jar;DestDir: {app}\thirdparty; Components: {#COMPN_GRAPHICS}
 ;
-Source: thirdparty\scirenderer-1.0.2.jar;DestDir: {app}\thirdparty; Components: {#COMPN_GRAPHICS}
+Source: thirdparty\scirenderer-1.0.3.jar;DestDir: {app}\thirdparty; Components: {#COMPN_GRAPHICS}
 ;
 Source: thirdparty\fonts\scilabsymbols.ttf;DestDir: {app}\thirdparty\fonts; Components: {#COMPN_GRAPHICS}
 ;
index de965f6..1074d78 100644 (file)
@@ -6,7 +6,7 @@ flexdock.jar=${thirdparty.dir}/flexdock-1.2.0.jar
 
 jgraphx.jar=${thirdparty.dir}/jgraphx.jar
 
-scirenderer.jar=${thirdparty.dir}/scirenderer-1.0.2.jar
+scirenderer.jar=${thirdparty.dir}/scirenderer-1.0.3.jar
 
 jogl2.jar=${thirdparty.dir}/jogl2.jar